summaryrefslogtreecommitdiff
path: root/modules/home/initial-home-setup.nix
diff options
context:
space:
mode:
authorTim Keller <tjk@tjkeller.xyz>2024-10-02 22:07:10 -0500
committerTim Keller <tjk@tjkeller.xyz>2024-10-02 22:07:10 -0500
commit4730b215fdc4095800fedfdf690c12fec994bb6b (patch)
tree3c746ece0089625a8093d4ae6bf1149ea903b7dc /modules/home/initial-home-setup.nix
parent34b0bb8df42194a0ea433592e3cac27546f0af4e (diff)
downloadnixos-4730b215fdc4095800fedfdf690c12fec994bb6b.tar.xz
nixos-4730b215fdc4095800fedfdf690c12fec994bb6b.zip
more reorganizing and modularizing
Diffstat (limited to 'modules/home/initial-home-setup.nix')
-rw-r--r--modules/home/initial-home-setup.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/home/initial-home-setup.nix b/modules/home/initial-home-setup.nix
new file mode 100644
index 0000000..a7119b9
--- /dev/null
+++ b/modules/home/initial-home-setup.nix
@@ -0,0 +1,18 @@
+{ config, lib, ... }: {
+ home.activation = {
+ cloneRepos = lib.hm.dag.entryAfter ["writeBoundary"] ''
+ export PATH="${config.home.path}/bin:$PATH"
+ ${builtins.readFile ./resources/activation-scripts/clone-repos.sh}
+ '';
+ linkZshProfile = lib.hm.dag.entryAfter ["writeBoundary"] ''
+ run ln -sf $VERBOSE_ARG $HOME/.config/zsh/zprofile $HOME/.zprofile
+ '';
+ cleanupHome = lib.hm.dag.entryAfter ["writeBoundary"] ''
+ run rm -f $VERBOSE_ARG $HOME/{.zcompdump,.zshrc,.zsh_history,.bash_history}
+ '';
+ mimewiz = lib.hm.dag.entryAfter ["writeBoundary"] ''
+ export PATH="$HOME/.local/bin/misc:$PATH"
+ run mimewiz # already verbose
+ '';
+ };
+}