summaryrefslogtreecommitdiff
path: root/modules/home/initial-home-setup.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/initial-home-setup.nix')
-rw-r--r--modules/home/initial-home-setup.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/home/initial-home-setup.nix b/modules/home/initial-home-setup.nix
new file mode 100644
index 0000000..a7119b9
--- /dev/null
+++ b/modules/home/initial-home-setup.nix
@@ -0,0 +1,18 @@
+{ config, lib, ... }: {
+ home.activation = {
+ cloneRepos = lib.hm.dag.entryAfter ["writeBoundary"] ''
+ export PATH="${config.home.path}/bin:$PATH"
+ ${builtins.readFile ./resources/activation-scripts/clone-repos.sh}
+ '';
+ linkZshProfile = lib.hm.dag.entryAfter ["writeBoundary"] ''
+ run ln -sf $VERBOSE_ARG $HOME/.config/zsh/zprofile $HOME/.zprofile
+ '';
+ cleanupHome = lib.hm.dag.entryAfter ["writeBoundary"] ''
+ run rm -f $VERBOSE_ARG $HOME/{.zcompdump,.zshrc,.zsh_history,.bash_history}
+ '';
+ mimewiz = lib.hm.dag.entryAfter ["writeBoundary"] ''
+ export PATH="$HOME/.local/bin/misc:$PATH"
+ run mimewiz # already verbose
+ '';
+ };
+}