summaryrefslogtreecommitdiff
path: root/modules/hosts/T495/configuration.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
committerTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
commit1835aa04051f2f0c41017423f2bcba6c549f26b0 (patch)
treeb5f26e29032e9084b27eeb0688c7a3a9bb0df57f /modules/hosts/T495/configuration.nix
parentd0faef2f53e2e5195b2acc7cc7bba898bd7cd05b (diff)
downloadnixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.tar.xz
nixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.zip
overhual
Diffstat (limited to 'modules/hosts/T495/configuration.nix')
-rw-r--r--modules/hosts/T495/configuration.nix32
1 files changed, 17 insertions, 15 deletions
diff --git a/modules/hosts/T495/configuration.nix b/modules/hosts/T495/configuration.nix
index 31b93f1..a3bad32 100644
--- a/modules/hosts/T495/configuration.nix
+++ b/modules/hosts/T495/configuration.nix
@@ -2,30 +2,29 @@
imports = [
./hardware-configuration.nix
./games.nix
+ ./input-leap.nix
./wg.nix
];
networking.hostName = "T495";
- # Use systemd-boot instead of grub
- # grub does not recognize fs
- grub.enable = false;
- boot.loader = {
- systemd-boot.enable = true;
- efi.canTouchEfiVariables = true;
- };
+ bootloader.mode = "efi";
# Enable extra software pkgs
- software = {
- desktop.extra.enable = true;
- dev.extra.enable = true;
+ software.desktop = {
+ chromium.enable = true;
+ cad.enable = true;
+ crypto.enable = true;
+ graphics.enable = true;
+ office.enable = true;
+ utilities.enable = true;
+ };
+ software.development = {
+ docker.enable = true;
};
- environment.systemPackages = with pkgs; [
- input-leap
- ];
- docker.enable = true;
# Enable network drives
- fs.networkFS.enable = true;
+ nas.enable = true;
+ nas.office.enable = true;
networking.hosts = {
"192.168.77.3" = [ "devel" ];
@@ -34,5 +33,8 @@
# Use amdgpu driver for x11
services.xserver.videoDrivers = [ "amdgpu" ];
+ # Enable bluetooth
+ bluetooth.enable = true;
+
system.stateVersion = "24.05";
}