summaryrefslogtreecommitdiff
path: root/modules/hosts/T495/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hosts/T495/configuration.nix')
-rw-r--r--modules/hosts/T495/configuration.nix32
1 files changed, 17 insertions, 15 deletions
diff --git a/modules/hosts/T495/configuration.nix b/modules/hosts/T495/configuration.nix
index 31b93f1..a3bad32 100644
--- a/modules/hosts/T495/configuration.nix
+++ b/modules/hosts/T495/configuration.nix
@@ -2,30 +2,29 @@
imports = [
./hardware-configuration.nix
./games.nix
+ ./input-leap.nix
./wg.nix
];
networking.hostName = "T495";
- # Use systemd-boot instead of grub
- # grub does not recognize fs
- grub.enable = false;
- boot.loader = {
- systemd-boot.enable = true;
- efi.canTouchEfiVariables = true;
- };
+ bootloader.mode = "efi";
# Enable extra software pkgs
- software = {
- desktop.extra.enable = true;
- dev.extra.enable = true;
+ software.desktop = {
+ chromium.enable = true;
+ cad.enable = true;
+ crypto.enable = true;
+ graphics.enable = true;
+ office.enable = true;
+ utilities.enable = true;
+ };
+ software.development = {
+ docker.enable = true;
};
- environment.systemPackages = with pkgs; [
- input-leap
- ];
- docker.enable = true;
# Enable network drives
- fs.networkFS.enable = true;
+ nas.enable = true;
+ nas.office.enable = true;
networking.hosts = {
"192.168.77.3" = [ "devel" ];
@@ -34,5 +33,8 @@
# Use amdgpu driver for x11
services.xserver.videoDrivers = [ "amdgpu" ];
+ # Enable bluetooth
+ bluetooth.enable = true;
+
system.stateVersion = "24.05";
}