summaryrefslogtreecommitdiff
path: root/modules/hosts/hp-envy-office/configuration.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-01-06 13:08:05 -0600
committerTim Keller <tjkeller.xyz>2025-01-06 13:08:05 -0600
commit9a92c148a04b66a9d5f665dc13ea60a8fbf0dd28 (patch)
treeafa5a0c4ed4ced0cf0ab2d4098c50dd235e61731 /modules/hosts/hp-envy-office/configuration.nix
parent1835aa04051f2f0c41017423f2bcba6c549f26b0 (diff)
downloadnixos-9a92c148a04b66a9d5f665dc13ea60a8fbf0dd28.tar.xz
nixos-9a92c148a04b66a9d5f665dc13ea60a8fbf0dd28.zip
add new host for office pc and automount func config
Diffstat (limited to 'modules/hosts/hp-envy-office/configuration.nix')
-rw-r--r--modules/hosts/hp-envy-office/configuration.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/modules/hosts/hp-envy-office/configuration.nix b/modules/hosts/hp-envy-office/configuration.nix
new file mode 100644
index 0000000..b6142c7
--- /dev/null
+++ b/modules/hosts/hp-envy-office/configuration.nix
@@ -0,0 +1,36 @@
+{ config, lib, pkgs, ... }: {
+ imports = [
+ ./hardware-configuration.nix
+ ];
+ networking.hostName = "hp-envy-office";
+
+ # Enable extra software pkgs
+ software.desktop = {
+ chromium.enable = true;
+ cad.enable = false;
+ crypto.enable = false;
+ graphics.enable = true;
+ office.enable = true;
+ utilities.enable = true;
+ };
+ software.development = {
+ docker.enable = true;
+ };
+
+ # Enable network drives
+ nas.enable = true;
+ nas.office.enable = true;
+ nas.home.enable = false;
+
+ networking.hosts = {
+ "192.168.77.3" = [ "devel" ];
+ };
+
+ # Use amdgpu driver for x11
+ services.xserver.videoDrivers = [ "amdgpu" ];
+
+ # Enable bluetooth
+ bluetooth.enable = true;
+
+ system.stateVersion = "24.11";
+}