summaryrefslogtreecommitdiff
path: root/modules/hosts/hp-envy-office/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hosts/hp-envy-office/configuration.nix')
-rw-r--r--modules/hosts/hp-envy-office/configuration.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/modules/hosts/hp-envy-office/configuration.nix b/modules/hosts/hp-envy-office/configuration.nix
new file mode 100644
index 0000000..b6142c7
--- /dev/null
+++ b/modules/hosts/hp-envy-office/configuration.nix
@@ -0,0 +1,36 @@
+{ config, lib, pkgs, ... }: {
+ imports = [
+ ./hardware-configuration.nix
+ ];
+ networking.hostName = "hp-envy-office";
+
+ # Enable extra software pkgs
+ software.desktop = {
+ chromium.enable = true;
+ cad.enable = false;
+ crypto.enable = false;
+ graphics.enable = true;
+ office.enable = true;
+ utilities.enable = true;
+ };
+ software.development = {
+ docker.enable = true;
+ };
+
+ # Enable network drives
+ nas.enable = true;
+ nas.office.enable = true;
+ nas.home.enable = false;
+
+ networking.hosts = {
+ "192.168.77.3" = [ "devel" ];
+ };
+
+ # Use amdgpu driver for x11
+ services.xserver.videoDrivers = [ "amdgpu" ];
+
+ # Enable bluetooth
+ bluetooth.enable = true;
+
+ system.stateVersion = "24.11";
+}