summaryrefslogtreecommitdiff
path: root/modules/root/secrets.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2024-10-20 20:17:28 -0500
committerTim Keller <tjkeller.xyz>2024-10-20 20:17:28 -0500
commitda8d6b77894dbf965fe77fd824512b6f160f906d (patch)
tree25cbc079dd89150d78eda20baf8d9793da12b352 /modules/root/secrets.nix
parent0b31d1d5ea46087a13c67889d427208f6612f01a (diff)
downloadnixos-da8d6b77894dbf965fe77fd824512b6f160f906d.tar.xz
nixos-da8d6b77894dbf965fe77fd824512b6f160f906d.zip
add age and sops pkgs. reluctantly add sops nix for managing secrets. change wifi config to use wpa supplicant and configure with secrets. wpa_gui installed.
Diffstat (limited to 'modules/root/secrets.nix')
-rw-r--r--modules/root/secrets.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/root/secrets.nix b/modules/root/secrets.nix
new file mode 100644
index 0000000..464a8f2
--- /dev/null
+++ b/modules/root/secrets.nix
@@ -0,0 +1,13 @@
+{ pkgs, inputs, config, userDetails, ... }: {
+ imports = [ inputs.sops-nix.nixosModules.sops ];
+
+ sops = {
+ defaultSopsFile = ./resources/secrets/secrets.yaml;
+ defaultSopsFormat = "yaml";
+ age.keyFile = "${userDetails.home.root}/.config/sops/age/keys.txt";
+
+ secrets = {
+ wireless-env = { };
+ };
+ };
+}