summaryrefslogtreecommitdiff
path: root/modules/root/secrets.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/root/secrets.nix')
-rw-r--r--modules/root/secrets.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/root/secrets.nix b/modules/root/secrets.nix
new file mode 100644
index 0000000..464a8f2
--- /dev/null
+++ b/modules/root/secrets.nix
@@ -0,0 +1,13 @@
+{ pkgs, inputs, config, userDetails, ... }: {
+ imports = [ inputs.sops-nix.nixosModules.sops ];
+
+ sops = {
+ defaultSopsFile = ./resources/secrets/secrets.yaml;
+ defaultSopsFormat = "yaml";
+ age.keyFile = "${userDetails.home.root}/.config/sops/age/keys.txt";
+
+ secrets = {
+ wireless-env = { };
+ };
+ };
+}